We are seeing a backlog of download requests queuing up and are actively working to resolve the bottleneck.
Posted Dec 09, 2025 - 11:12 CST
Update
The downloads backlog has been cleared and we are continuing to monitor performance.
Posted Dec 04, 2025 - 15:33 CST
Update
We are seeing a backlog of download requests queuing up and are actively working to resolve the bottleneck.
Posted Dec 04, 2025 - 14:12 CST
Update
We have deployed a change that improves the performance of several downloads queries and allocates more processing bandwidth. We expect throughput to exceed levels seen prior to this incident but are continuing to monitor the system to ensure that is the case.
Posted Dec 04, 2025 - 07:53 CST
Update
We made another configuration change on the evening of Thursday, Nov 20 to further increase the download throughput. We are monitoring the impact.
Posted Nov 21, 2025 - 08:15 CST
Update
We observed some instability with downloads overnight. We are continuing to address the downloads throughput and will continue to monitor the situation.
Posted Nov 19, 2025 - 09:36 CST
Update
We will continue to monitor to ensure that downloads are being processed efficiently.
Posted Nov 14, 2025 - 14:42 CST
Monitoring
The configuration update has been deployed and we are monitoring the impact
Posted Nov 13, 2025 - 07:01 CST
Identified
We have identified the cause of the slower processing and are preparing a configuration update to ease the bottleneck.
Posted Nov 12, 2025 - 12:45 CST
Investigating
We are aware of downloads being processed less quickly than usual. Our team is actively investigating the underlying cause.
Posted Nov 12, 2025 - 11:20 CST
This incident affects: serviceminder.io web and serviceminder.io API.