Unable to schedule appointments

Incident Report for serviceminder.io

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 15:45 CDT

Monitoring

The rollback has completed, and we are monitoring the situation.
Posted Apr 20, 2026 - 15:29 CDT

Identified

The issue has been identified. A rollback to a previous version is currently being performed.
Posted Apr 20, 2026 - 14:57 CDT

Investigating

We are currently investigating an issue preventing the scheduling of appointments.
Posted Apr 20, 2026 - 14:54 CDT
This incident affected: serviceminder.io web.