Access to ServiceMinder has been restored and the application is functioning normally. We are monitoring closely and continuing to investigate the root cause.
Posted Sep 01, 2026 - 12:22 CDT
Identified
We have identified a database capacity issue affecting access to ServiceMinder. We are scaling the database to restore service.
Posted Sep 01, 2026 - 12:15 CDT
Investigating
We are currently investigating the issue.
Posted Sep 01, 2026 - 12:00 CDT
This incident affected: serviceminder.io web, serviceminder.io app, and serviceminder.io API.