Page load times are now consistently in normal range.
Posted Aug 27, 2025 - 17:57 CDT
Monitoring
The root cause was temporary overload on a read-only database instance.
Posted Aug 27, 2025 - 17:17 CDT
Investigating
Higher than normal page load times may have been experienced because a number of our web servers were timing out while processing requests. The issue has been resolved but we are actively monitoring the situation and working to identify the root cause.